1. HOT Divi Ultimate Header Plugin - Design Divi custom header globally in Divi Builder: https://header.diviultimate.com/
    Dismiss Notice

Background color shows on desktop but not mobile

Discussion in 'Get Help On Divi Wordpress' started by Nick Lotter, Apr 11, 2019.

  1. Nick Lotter

    Nick Lotter New Member

    I have a module on my home page with the background color set to a gradient of blue and black. It shows up beautifully on desktop, but it shows up as a white background on my smartphone. I am using Chrome on both. This is a bad situation, because the text is white so it looks terrible on the phone.

    The advanced settings on the module have not been set to be invisible on phone or tablet.

    Another weird thing is that my Google analytics code is now showing in a little white strip at the bottom on my phone's screen when I am on the home page.

    What could be causing these two issues?
     

    Attached Files:

  2. Divi.Help

    Divi.Help Administrator
    Staff Member

    Kindly share your URL.
     
  3. Divi.Help

    Divi.Help Administrator
    Staff Member

    The background color shows up fine in mobile.

    As for the Google analytics code, I'm not sure what's causing it. Just a guess: Did you add it in Divi > Theme Options > Integration > Body code? If so, you might want to check if you accidentally place the code outside of the <script> tag.
     
  4. Nick Lotter

    Nick Lotter New Member

    Ok weird... it still shows up as a white background on my phone. Maybe its a cache issue

    This is what I have in my body code:

    UA-xxxxxxxxx
    <!-- Global site tag (gtag.js) - Google Analytics -->
    <script async src="https://www.googletagmanager.com/gtag/js?id=UA-120462681-1"></script>
    <script>
    window.dataLayer = window.dataLayer || [];
    function gtag(){dataLayer.push(arguments);}
    gtag('js', new Date());

    gtag('config', 'UA-xxxxxxxxxx');
    </script>
     
  5. Divi.Help

    Divi.Help Administrator
    Staff Member

    I believe the first line (not in the <script> tag) is causing the issue. Try removing the first line.