1. HOT Divi Ultimate Header Plugin - More variety for your Divi header: https://header.diviultimate.com/

Solved Divi blog module is not visible

Discussion in 'Free Divi Community Forum' started by gokul, Jan 13, 2020.

  1. gokul

    gokul New Member

    Hi,
    My Divi blog module is not showing the posts (not working in both grid & full-width form). The posts are only visible when I am login to my site.

    Things I tried:
    • I have changed the animation to fade, bounce, etc.
    • disabled all the plugin via divi support center.
    • changed my theme & then back to divi
    • updated divi theme to the latest version 4.1
    • again downgraded to 4.0.8
    None of the above 5 things worked for me.

    How can I fix this? My site URL- https://www.digirockstar.com

    Thank You.
     
    1. AD Speed up your Divi site with Divi specific cache plugin: https://divi.help/link-forums/divi-rocket.160/
  2. Divi.Help

    Divi.Help Administrator
    Staff Member

    Try to disable Autoptimize plugin & see if it works.
     
  3. gokul

    gokul New Member

    Hi,
    I have disabled autoptimize plugin. But it didn't work.

    Is there any other way to fix this?

    Thank You.
     
    1. AD Set awesome default design for your Divi single blog page: https://blog.diviultimate.com/
  4. Divi.Help

    Divi.Help Administrator
    Staff Member

    Most likely a JS issue. From the browser console, I still can see that Autoptimize JS is missing, which I suspect that it's causing the blog missing issue.

    upload_2020-1-15_11-21-58.png
     
  5. gokul

    gokul New Member

    Thank You So Much. The issue is fixed now.:)
     
    1. AD Awesome ways to display testimonials in your Divi site: https://divi.help/link-forums/testimonial-slider.148/
  6. Rade

    Rade New Member

    Hi gokul,
    I have the same problem as you. Can you tell me what you did to solve the problem?
    thanks
    Rade
     
  7. gokul

    gokul New Member

    Hi Rade,

    I don't remember what I did. But you can try removing the animation.

    Another thing you can try is by updating your site to the latest version of WP & Divi.

    in my case, I think it was because of autoptimize plugin. So, If you are using autoptimize plugin, then let me know. I will share my autoptimize settings.
     
    1. AD Awesome ways to display testimonials in your Divi site: https://divi.help/link-forums/testimonial-slider.148/
  8. Rade

    Rade New Member

    Hi gokul, thanks for your reply,
    I installed the Autoptimize Plugin, but with the intention of solving the problem that way. The problem existed even before the installation of Autoptimize.
    What I tried was to backup the site using the UpdraftPlus plugin, and did a restore to another site located on another hosting provider to see if it would work properly.
    However, when I did the restore, I got error information:
    Warning: require(/usr/share/php/wp-stack-cache.php): failed to open stream: No such file or directory in /home3/dealwork/mytopdomain.com/wp-content/mu-plugins/wp-stack-cache.php on line 31

    Warning: require(/usr/share/php/wp-stack-cache.php): failed to open stream: No such file or directory in /home3/dealwork/mytopdomain.com/wp-content/mu-plugins/wp-stack-cache.php on line 31

    Fatal error: require(): Failed opening required '/usr/share/php/wp-stack-cache.php' (include_path='.:/opt/php71/lib/php') in /home3/dealwork/mytopdomain.com/wp-content/mu-plugins/wp-stack-cache.php on line 31
    There has been a critical error on this website. Please check your site admin email inbox for instructions.Learn more about debugging in WordPress.

    Could it be that the problem is caused by the StackCache Plugin? I see StackCache in the admin wordpress panel, but it's not in Plugins...
     
  9. gokul

    gokul New Member

    Hi,

    I will suggest you to go to divi> support center & turn on safe mode. This will temporary deactivate all your plugins & see if everything is ok or not. If everything is working fine then activate your plugins one by one.

    I haven't used stack cache plugin so can't say anything about this plugin.
     
    1. AD Use modules from the Extra theme with the Divi Builder: https://divi.help/link-forums/divi-extra.163/
  10. Zlatko

    Zlatko New Member

    Same thing here, Blog module just stopped working.

    Visible when logged in as Admin but not in incognito

    Safe mode disables all but still not showing .
     
  11. gokul

    gokul New Member

    In my case, the blog module grid layout was not showing but it was working fine with full width. I think I removed the animation & after that, It was working fine.

    I will suggest you update your site to the latest version of Divi, WordPress & see it is showing or not. If these things don't work then you can contact the official divi support.

    You can also join the Divi Facebook group.
     
    1. AD Add more variety for your Divi header (12 premade styles): https://header.diviultimate.com/