1. HOT Divi Ultimate Header Plugin - Design Divi custom header globally in Divi Builder: https://header.diviultimate.com/
    Dismiss Notice

Issue w/ dividers on Mobile

Discussion in 'Get Help On Divi Wordpress' started by JulienBern, Jun 7, 2019.

  1. JulienBern

    JulienBern New Member

    Hello everyone,

    I’ve had an issue with Divi + the dividers on mobile that I haven’t been able to solve for a while now.

    I created my homepage and added "dividers" between the sections to have a cool visual effect, but a problem occurs with the mobile version: when I go on mobile the dividers appears/disappear as I stay on the page scrolling up and down (or sometimes without even touching it). It seems like there is a javascript problem or a fixed: position problem but I don't know where to fix that, would you have an idea on this ?
    It seems like a css line to make the dividers appears on top could be enough?

    A: The sections themselves are built with SmartSlider.
    B: The problem occurs on IPhone 7&8 & maybe others
    C: It works perfectly on desktop

    Thank you!
    (See attached files for screenshots)
     
  2. Divi.Help

    Divi.Help Administrator
    Staff Member

    Can't say for sure what's happening without accessing the URL. Perhaps it's a z-index issue. Try to add a high z-index value for your divider. If your divider is wrapped in a separate row / section, then set the high z-index in the row / section.
     
  3. JulienBern

    JulienBern New Member

    Hello, thank you for your answer. What would be the css to add to the dividers ? Can’t manage to find the css of the dividers when I try to inspect the page. If you wanna have a look:
    https://ephemere.black (open in a new window)
    ID: admin
    PSW: julien0105!
     
  4. Divi.Help

    Divi.Help Administrator
    Staff Member

    Try to add the below CSS in Divi > Theme Options > Custom CSS & see if it works:
    Code:
    .et_pb_bottom_inside_divider, .et_pb_top_inside_divider {
        z-index: 999!important;
    }
    If not, try to put a high z-index like 99999 & see if it works. If still not working, then you might want to refer smart slider support & see what they say.